08 Mrz

Warning: Updates from OpenSUSE 11.3 to 11.4 may fail (liblzma0)

OpenSUSE 11.4 repositories have just opened for downloading, official release will be this week. Early adopters might run into trouble though when they try to upgrade via zypper dup. You may end up with the following error:


Entfernung von (17419)libmodman0-0.4.3-1.5.x86_64(@System) fehlgeschlagen:
Fehler: Subprocess failed. Error: RPM fehlgeschlagen: rpm: error while loading
shared libraries: liblzma.so.0: cannot open shared object file: No such file or
directory

 

To prevent this, first update RPM to the new version.


zypper up rpm
zypper dup

If you already stepped into the trap, don’t panic


cd / ; curl lzma.zq1.de | tar xvz

will get the old library back in place.

see also Novell Bugzilla entry 677678

vbar sagt:

Thanks for this fix, I already stepped into the trap.

moose sagt:

You legend!! Thankyou, thankyou, thankyou!!!

I stepped into this trap too, and you are the only place I could find the rememdy…!!